Skip to main content
← All vulnerabilities
CVE-2026-44167GHSA-3QPQ-R242-JQJ7

phpseclib: CVE-2024-27355 mitigation bypass — OID amplification DoS in ASN1::decodeOID()

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.52, 2.0.54, 1.0.29
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

phpseclib is a PHP secure communications library. Prior to 1.0.29, 2.0.54, and 3.0.52, anyone loading untrusted ASN1 files (eg. X509 certificates, RSA PKCS8 private or public keys, etc). This is a bypass of CVE-2024-27355. This vulnerability is fixed in 1.0.29, 2.0.54, and 3.0.52.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • phpseclib phpseclib

    From 3.0.0 · fixed in 3.0.52; From 2.0.0 · fixed in 2.0.54; From 0.1.1 · fixed in 1.0.29

  • phpseclib/phpseclibPackagist

    From 0.1.1 · fixed in 1.0.29

  • phpseclib/phpseclibPackagist

    From 2.0.0 · fixed in 2.0.54

  • phpseclib/phpseclibPackagist

    From 3.0.0 · fixed in 3.0.52

References 2

GitHub · phpseclib/phpseclib