Skip to main content
← All vulnerabilities
CVE-2026-43944GHSA-MPM8-CX2P-626Q

electerm: dangerous code can be run through links or command line

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.8.15, 3.8.8
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. From versions 3.0.6 to before 3.8.15, electerm is vulnerable to arbitrary local code execution via deep links, CLI --opts, or crafted shortcuts. Exploit requires clicking a crafted electerm://... link or opening a crafted shortcut/command that launches electerm with attacker-controlled opts. This issue has been patched in version 3.8.15.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • electerm electerm

    From 3.0.6 · fixed in 3.8.15

  • electermnpm

    From 3.0.6 · fixed in 3.8.8

References 5

GitHub · electerm/electerm