Skip to main content
← All vulnerabilities
CVE-2026-42797GHSA-VR35-JM2F-8WG2

Apache Syncope: JexlContextBuilder Information Disclosure

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.6, 4.1.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.syncope.core:syncope-core-provisioning-api

    From 3.0 · through 3.0.16; From 4.0 · through 4.0.5; From 4.1 · through 4.1.0

  • org.apache.syncope.core:syncope-core-provisioning-apiMaven

    From 3.0.0-M0 · through 3.0.16

  • org.apache.syncope.core:syncope-core-provisioning-apiMaven

    From 4.0.0-M0 · fixed in 4.0.6

  • org.apache.syncope.core:syncope-core-provisioning-apiMaven

    From 4.1.0-M0 · fixed in 4.1.1

References 1

lists.apache.org