Skip to main content
← All vulnerabilities
CVE-2026-42782GHSA-GQ7G-VG2Q-JVQ3

Apache Syncope: Post-auth RCE via Groovy static

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.6, 4.1.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Improper Isolation or Compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class containing untrusted code reaching a non-sandboxed execution path via the class static initializer. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by forcing even the static initializer in Groovy code to run in a sandbox.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • org.apache.syncope.core:syncope-core-spring

    From 3.0 · through 3.0.16; From 4.0 · through 4.0.5; From 4.1 · through 4.1.0

  • org.apache.syncope.core:syncope-core-springMaven

    From 3.0.0-M0 · through 3.0.16

  • org.apache.syncope.core:syncope-core-springMaven

    From 4.0.0-M0 · fixed in 4.0.6

  • org.apache.syncope.core:syncope-core-springMaven

    From 4.1.0-M0 · fixed in 4.1.1

References 1

lists.apache.org