Skip to main content
← All vulnerabilities
CVE-2026-41989

Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.10.4, 1.11.3, 1.12.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Libgcrypt before 1.12.2 sometimes allows a heap-based buffer overflow and denial of service via crafted ECDH ciphertext to gcry_pk_decrypt.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • gnupg Libgcrypt

    From 1.8.8 · fixed in 1.10.4; From 1.11.0 · fixed in 1.11.3; From 1.12.0 · fixed in 1.12.2

References 3

lists.gnupg.org

dev.gnupg.org

openwall.com