Skip to main content
← All vulnerabilities
CVE-2026-41988GHSA-W5HQ-G745-H8PQ

uuid before 14.0.0 can make unexpected writes when external output buffers are used, and the UUID version is 3, 5, or 6.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.0.0, 11.1.1, 12.0.1, 13.0.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

uuid before 14.0.0 can make unexpected writes when external output buffers are used, and the UUID version is 3, 5, or 6. In particular, UUID version 4, which is very commonly used, is unaffected by this issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • uuidjs uuid

    fixed in 14.0.0

  • uuidnpm

    fixed in 11.1.1

  • uuidnpm

    From 12.0.0 · fixed in 12.0.1

  • uuidnpm

    From 13.0.0 · fixed in 13.0.1

References 2

GitHub · uuidjs/uuid