Skip to main content
← All vulnerabilities
CVE-2026-41839GHSA-4HFH-6X8G-GWPP

Spring Framework Escalation via Session Fixation in WebFlux

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.0.7.1, 6.2.18.1, 6.1.28, 5.3.49, 7.0.8, and 1 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

A WebFlux application with a compromised subdomain (for example, compromised via cross-site scripting (XSS)) is vulnerable to an escalation attack exchanging a known session ID for that of an authenticated user. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Spring Spring Framework

    From 7.0.0 · fixed in 7.0.7.1; From 6.2.0 · fixed in 6.2.18.1; From 6.1.0 · fixed in 6.1.28; From 5.3.0 · fixed in 5.3.49

  • org.springframework:spring-webfluxMaven

    From 7.0.0 · fixed in 7.0.8

  • org.springframework:spring-webfluxMaven

    From 6.2.0 · fixed in 6.2.19

  • org.springframework:spring-webfluxMaven

    From 6.1.0 · through 6.1.21

  • org.springframework:spring-webfluxMaven

    through 5.3.39

References 1

spring.io